<!DOCTYPE html>
<!--[if IE 8]> <html lang="en-US" class="no-js ie-browser lt-ie9"> <![endif]-->
<!--[if IE 9]> <html lang="en-US" class="no-js ie-browser ie9"> <![endif]-->
<!--[if gt IE 9]><!--> <html lang="en-US" class="no-js"> <!--<![endif]-->
<head>

	<script>(function(H){H.className=H.className.replace(/\bno-js\b/,'js')})(document.documentElement)</script>

	<meta charset="UTF-8">
	<meta http-equiv="X-UA-Compatible" content="IE=Edge">
	<meta name="viewport" content="width=device-width, initial-scale=1.0">

	<link rel="profile" href="http://gmpg.org/xfn/11">
	<link rel="pingback" href="https://theclemsoninsider.com/xmlrpc.php">

	
	<!--[if lt IE 9]>
    <script src="https://theclemsoninsider.com/wp-content/themes/usatoday-lawrence/js/lib/html5.js" type="text/javascript"></script>
	<link rel="stylesheet" type="text/css" href="https://theclemsoninsider.com/wp-content/themes/usatoday-lawrence/ie8.css">
	<![endif]-->

	<!--[if gte IE 9]>
	<link rel="stylesheet" type="text/css" href="https://theclemsoninsider.com/wp-content/themes/usatoday-lawrence/ie9.css">
	<![endif]-->

	
	
<meta name="description" content="Saturday will certainly be a special day for many Clemson seniors including Darien Rencher. Saturday&#039;s home finale against Pittsburgh may be the last time the senior running back goes down the hill as a player." />
<meta name="keywords" content="feature, football, clemson football, darien rencher, pitt football" />
<title>Rencher ready for another moment in his Clemson journey | The Clemson Insider</title>
<link rel='dns-prefetch' href='//native.sharethrough.com' />
<link rel='dns-prefetch' href='//mtrx.go.sonobi.com' />
<link rel='dns-prefetch' href='//usatodaysports-d.openx.net' />
<link rel='dns-prefetch' href='//embed.air.tv' />
<link rel='dns-prefetch' href='//js-sec.indexww.com' />
<link rel='dns-prefetch' href='//cdn.adsafeprotected.com' />
<link rel='dns-prefetch' href='//confiant-integrations.global.ssl.fastly.net' />
<link rel='dns-prefetch' href='//www.googletagservices.com' />
<link rel='dns-prefetch' href='//cdn.onesignal.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel="alternate" type="application/rss+xml" title="The Clemson Insider &raquo; Feed" href="https://theclemsoninsider.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Clemson Insider &raquo; Comments Feed" href="https://theclemsoninsider.com/comments/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/theclemsoninsider.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.5.2"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='all-css-0' href='https://theclemsoninsider.com/_static/??-eJxtztEOgyAMBdAfGlaj2duyb0FotsYKhJYt/L04Y/bia9t7euGbDAXHxaOAEwFPojBzdIthmrPNFUQrY7dS6NrBDVrCxaAYFNZiEpcXBQFBm90bkK0ouZTxtHY0t7GiNymKijn0nyqX7GkWsRq9rf8njV5qK8wU0HzIYzxaXy129rk+hns/9f04TsMGoRRYcQ==' type='text/css' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify{text-align:justify;}
</style>
<link crossorigin="anonymous" rel='stylesheet' id='tci-fonts-css'  href='//fonts.googleapis.com/css?family=News+Cycle%3A400%2C700&#038;ver=5.5.2' media='all' />
<link rel='stylesheet' id='all-css-2' href='https://theclemsoninsider.com/_static/??-eJx9zMsOgjAQheEXsgwQIXFhfAzXwzBKtS0NZxrC23uJJq5cnvz5Dq3ZyZxMk5FNGhVUwDaPvLnA66JJ9BvODB58JcCOflgsLody9QkE5UUm0sAwL3lRgEYPo6ehC4saHGwLiir69O/pppZZ7u5QNW/82S9yisemr/dd3bdd+wB6JEZv' type='text/css' media='all' />
<script>var googletag_cmd_push = function(o){ return googletag.cmd.push( o ); };</script><script id='amazon-adsystem-js-extra'>
var amznAcctId = ["3090"];
</script>
<script id='amazon-adsystem-js-before'>
!function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function(){q("f",arguments)},setDisplayBids:function(){},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];g.parentNode.insertBefore(A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");window.bidSlots=window.bidSlots||[];window._mweb=0;apstag.init({pubID: amznAcctId[0], adServer: "googletag"});
</script>
<script src='https://theclemsoninsider.com/wp-content/themes/usatoday-lawrence/js/bidder-manager.js?ver=5.5.2' id='amazon-adsystem-js'></script>
<script src='https://mtrx.go.sonobi.com/morpheus.usatoday.1587.js?ver=5.5.2' id='sonobi-adsystem-js'></script>
<script src='https://usatodaysports-d.openx.net/w/1.0/jstag?nc=7103-USA_RON&#038;ver=5.5.2' id='openx-adsystem-js'></script>
<script src='https://embed.air.tv/v1/twoview_bootstrap.js?organization=Q764rbL8R_6N0U_PaTy7oQ&#038;ver=5.5.2' id='air-tv-script-js'></script>
<script src='https://js-sec.indexww.com/ht/p/184031-126856402220676.js?ver=5.5.2' id='lawrence-header-bidding-js'></script>
<script src='https://cdn.adsafeprotected.com/iasPET.1.js?ver=5.5.2' id='lawrence-ads-ias-js'></script>
<script id='lawrence-ads-ias-js-after'>
var iasDataHandler, __iasPET = __iasPET || {};
				__iasPET.queue = __iasPET.queue || [];
				__iasPETSlots = [];
				__iasPET.pubId = '922805';
				bidManager.addBidder( 'ias' );
			
</script>
<script id='tracking-head-js-extra'>
var gtmContainerId = "GTM-ML9LGVK";
</script>
<script type='text/javascript' src='https://theclemsoninsider.com/_static/??/wp-includes/js/jquery/jquery.js,/wp-content/themes/usatoday-lawrence/modules/google-tag-manager/js/tracking-head.js?m=1604003342j'></script>
<script id='lawrence-ad-marketplace-sponsored-search-results-js-js-extra'>
var lawrence_ad_marketplace_data = {"endpoint":"","suggest_endpoint":"https:\/\/usatoday_cps.cps.ampfeed.com\/suggestions?partner=usatoday_cps&sub1=partner&sub2=theclemsoninsider.com&sub3=paidsuggest&v=1.1&callback=1606568814&out=json","sponsored_text":"Sponsored","ads_by_text":"Ads by adMarketplace"};
</script>
<script src='https://theclemsoninsider.com/wp-content/themes/usatoday-lawrence/modules/ad-marketplace/js/sponsored-search-results.js?ver=1.0.0' id='lawrence-ad-marketplace-sponsored-search-results-js-js'></script>
<script async src='https://confiant-integrations.global.ssl.fastly.net/FvW3szAY_s729BZEa4_yfA6omyQ/gpt_and_prebid/config.js?ver=1.0.0' id='lawrence-confiant-js'></script>
<script id='usatoday-gallery-js-extra'>
var usatoday_gallery_ajax_object = {"publisherGA":"UA-7784734-1","sharethispubid":"fd7eb3e3-60ab-4eeb-9e7b-cb89e8ec8c83"};
var _usmgOptions = {"ipdir":"r","gaid":"UA-7784734-1","dfpid":"7103","pid":"SMG_TheClemsonInsider","ads":[],"tlmurl":"http:\/\/tags.tiqcdn.com\/utag\/gci\/clemsoninsider\/prod\/utag.js"};
</script>
<script type='text/javascript' src='https://theclemsoninsider.com/_static/??-eJylkOEKwjAMhF/IrlZE3Q/xWWqXzXRtV5fUube3AyeiIAz/JXd8Ry5yiMJ0gSGwjC41GEgm0txVehSzoCOKRjsHPULeiIBJWpIM2mHyT28sLK3kP3mJqpj1IVviporNZyBfwMNbntNDD8HAxFKLUTgMrag7k0jUeF+C22uaGniNYQnm8DyjxGjarx/8PBmr/kXnObMnf1S7tdqWB1Xu7QNgBJts'></script>
<link rel="https://api.w.org/" href="https://theclemsoninsider.com/wp-json/" /><link rel="alternate" type="application/json" href="https://theclemsoninsider.com/wp-json/wp/v2/posts/552984" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://theclemsoninsider.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://theclemsoninsider.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.5.2" />
<link rel='shortlink' href='https://theclemsoninsider.com/?p=552984' />
<link rel="alternate" type="application/json+oembed" href="https://theclemsoninsider.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ftheclemsoninsider.com%2F2020%2F11%2F28%2Frencher-ready-for-another-moment-in-his-clemson-journey%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://theclemsoninsider.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ftheclemsoninsider.com%2F2020%2F11%2F28%2Frencher-ready-for-another-moment-in-his-clemson-journey%2F&#038;format=xml" />
<style type='text/css'>img#wpstats{display:none}</style>
<meta name="gdpr" content="false" />
<link rel="manifest" href="/manifest.json"><style type="text/css">
.articleBody a,
.article__pagination a,
.author__description a,
.search-no-results .entry-content a,
.archive-no-results .entry-content a,
.nav__item--parent > a:after,
.nav__item--podcast .nav__item-link,
.mobile-nav__item--podcast .mobile-nav__item-link,
.mobile-nav__footer-menu .mobile-nav__item a:active,
.trending__item:before,
.trending__link,
.hero__shares,
.column h3 > a:hover,
.second-tab-content p > a:hover,
.single-related p > a:hover,
.widget--box .text-block a:hover,
.widget--section-promo p > a:hover,
.column .meta-info a,
.zone--video .medium .author a,
.block--hero .reply-block,
.social-cta__button,
.social-cta__notice--error,
#footer-info .togglee a:hover,
#footer-info .togglee a:active,
.article__subheading,
.articleBody h2,
.search-no-results .entry-content h2,
.archive-no-results .entry-content h2,
.article__author a,
.author__twitter a,
.articleBody .pq,
.search-no-results .entry-content .pq,
.archive-no-results .entry-content .pq,
.single-related .block__shares,
.widget--section-promo .block__shares,
.article__back:before,
.article__back:hover,
.archive .heading .taxonomy,
.search-results .heading .taxonomy,
.search-results .heading > span,
.archive.author .heading h1 a,
.widget_text .textwidget a,
.sidebar-upper .widget_usat_sidebar_top_posts_widget .text-block > h2,
.sidebar-upper .widget_usat_sidebar_top_posts_widget .text-block > h2 > a,
.sidebar-upper .widget_usat_sidebar_top_posts_widget .text-block .shares,
.widget--box .text-block > h2,
.widget--box .text-block > h2 > a,
.widget--author a,
.newsletter-close-alt a,
.related .block__title:hover,
.hero__secondary .hero__link:hover .hero__title,
.widget_usat_sidebar_top_posts_widget .reply-block .social-count,
.ad-marketplace-search-result-link {
	color: #e96b30;
}

.mobile-stream-tabs h2,
.column .heading-small h2,
.sidebar-upper .widget .heading-small h2,
.single-related .heading-small h2,
#video-container .heading-small h2,
.mobile-stream-tabs > div {
	border-bottom-color: #e96b30;
}

@media all and (min-width: 1000px) {
	.branding__logo-link {
		border-bottom-color: #e96b30;
	}
}

.article__pagination .article__pagination__button:hover,
.article__pagination .article__pagination__link:hover,
.article__pagination .article__pagination__button:active,
.article__pagination .article__pagination__link:active {
	border-color: #e96b30;
}

.nav__item:hover,
.nav__item--current,
#footer-info,
.ad-marketplace-sponsored-text {
	border-top-color: #e96b30;
}

.articleBody blockquote:not(.pq),
.search-no-results .entry-content blockquote:not(.pq),
.archive-no-results .entry-content blockquote:not(.pq) {
	border-left-color: #e96b30;
}

.newsletter-modal {
	border-top: solid 8px #e96b30;
}

.article__back {
	border-color: #e96b30;
}

.vertical-gallery--icon,
.smg-event--icon,
.vertical-gallery__overlay,
.listicle__overlay,
.hero__label,
.column .block .img-holder .meta,
.second-tab-content h2,
.single-related .fixed-height-img-holder.link .meta,
.mobile-nav__menu .mobile-nav__item > a:active,
.mobile-nav__menu .mobile-nav__item--current > a,
.article__pagination__current,
.articleBody:after,
.search-no-results .entry-content:after,
.archive-no-results .entry-content:after,
.story-share-buttons .share-count,
.daily-newsletter__button {
	background-color: #e96b30;
}

.newsletter__button {
	background-image: linear-gradient(to bottom, rgba(0, 0, 0, 0), rgba(0, 0, 0, 0.12)),
		linear-gradient(#e96b30, #e96b30)
}

.newsletter__button:after,
.daily-newsletter__button:after {
	background-color: #e96b30;
}

@media all and (min-width: 1000px) {
	.branding {
		border-bottom-color: #e96b30;
	}
}

.smg-event__ctabutton {
	background-color: #e96b30;
	box-shadow: 0 2px 0 0 #e96b30;
}
</style>
<link rel="canonical" href="https://theclemsoninsider.com/2020/11/28/rencher-ready-for-another-moment-in-his-clemson-journey/" />

<!-- Include google_services.js -->
<script async="async" src="https://www.googletagservices.com/tag/js/gpt.js"></script>
<script>
	var bottomAdMobileRendered = false,
		googletag = googletag || {},
		bidTimeout;
	googletag.cmd = googletag.cmd || [];
	bidManager.timeout = 2500;
	bidManager.addBidder('a9');
		bidManager.addBidSlot({ slotID: "videoSlot", mediaType : 'video' } );

	</script>
<!-- helper function for targeting the url -->
<script type='text/javascript'>
(function(e,t){function i(){e.googletag=e.googletag||{};e.sdpTargeting=this.urlTargeting();e._sitePage=e.sdpTargeting.sp}var n,r;i.prototype.urlTargeting=function(){var t=e.location.pathname.replace(/\/$/,""),n=new RegExp("/([^/]*)","ig"),r=t.match(n),i=["/"],s="";if(r&&t!=="/"){var o="",u=r.length;if(u>0){for(var a=0;a<u;a++){o=r[a];i.push(o);for(var f=a+1;f<u;f++){o+=r[f];i.push(o)}if(a===0){i.splice(-1,1);s=o}}}i.push(s)}i=i.reverse();var l=e.location.toString().replace(/\=/ig,":").match(/\?(.+)$/),c=RegExp.$1.split("&"),h=e.location.toString().replace(/\/*(\?|\&|\x26)*(\w+=\w+)*$/,"");var p=h.replace(/http:\/\//,"").split("/");var d=p.length==1?"main":p[1].match(/^$|^index\.(php|htm|html)+$/i)?"main":"general";return{title:h,targetPaths:i.slice(0,9),fullPath:i[0],queryStr:c,domainName:e.location.hostname,sp:d}};n=new i})(window,document)
</script>
<script type='text/javascript'>
if (typeof amznads !== "undefined") {
	var key = 'amznslots';
	var values = amznads.getTokens(); //comma separated
}
</script>
<script type='text/javascript'>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</script>
<link rel="amphtml" href="https://theclemsoninsider.com/2020/11/28/rencher-ready-for-another-moment-in-his-clemson-journey/amp/">
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Rencher ready for another moment in his Clemson journey" />
<meta property="og:url" content="https://theclemsoninsider.com/2020/11/28/rencher-ready-for-another-moment-in-his-clemson-journey/" />
<meta property="og:description" content="Saturday will certainly be a special day for many Clemson seniors including Darien Rencher. Saturday&#8217;s home finale against Pittsburgh may be the last time the senior running back goes down th…" />
<meta property="article:published_time" content="2020-11-28T11:32:40+00:00" />
<meta property="article:modified_time" content="2020-11-28T11:32:40+00:00" />
<meta property="og:site_name" content="The Clemson Insider" />
<meta property="og:image" content="https://theclemsoninsider.com/wp-content/uploads/sites/81/2019/10/darien-rencher-1.jpg?w=1024&amp;h=576&amp;crop=1" />
<meta property="og:image:width" content="1024" />
<meta property="og:image:height" content="576" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:text:title" content="Rencher ready for another moment in his Clemson journey" />
<meta name="twitter:image" content="https://theclemsoninsider.com/wp-content/uploads/sites/81/2019/10/darien-rencher-1.jpg?w=640" />
<meta name="twitter:card" content="summary_large_image" />
<meta property="article:publisher" content="https://www.facebook.com/theclemsoninsider" />

<!-- End Jetpack Open Graph Tags -->
<link rel="icon" href="https://theclemsoninsider.com/wp-content/uploads/sites/81/2020/09/cropped-TCIIcon.png?w=32" sizes="32x32" />
<link rel="icon" href="https://theclemsoninsider.com/wp-content/uploads/sites/81/2020/09/cropped-TCIIcon.png?w=192" sizes="192x192" />
<link rel="apple-touch-icon" href="https://theclemsoninsider.com/wp-content/uploads/sites/81/2020/09/cropped-TCIIcon.png?w=180" />
<meta name="msapplication-TileImage" content="https://theclemsoninsider.com/wp-content/uploads/sites/81/2020/09/cropped-TCIIcon.png?w=270" />
		<style type="text/css" id="wp-custom-css">
			/*
Welcome to Custom CSS!
To learn how this works, see http://wp.me/PEmnE-Bt
*/
#wrapper {
}

#header-ad {
	background-color: #53247c;
}

.nav__menu, .nav__wrap, .nav__social {
	background-color: #53247c;
}

.nav__item--current {
	background-color: #3c1a5a;
}

.nav__item--current > a {
	color: #cccccc;
}

.nav__item .sub-menu, .nav__item:hover {
	background-color: #471f6a;
}

.nav__item .sub-menu li:hover, .sub-menu .nav__item--current {
	background-color: #3c1a5a;
}

@media only screen and (min-width: 730px)
.alignleft.size-medium.wp-post-image {
	
}

div #text-3 {
	display: none;
	visibility: hidden;
}

/* Remove floating link from homepage */
.mobile-nav__breadcrumb {
	display: none;
}

/*
iframe fixes
*/
#post-468223 .entry-content {
	padding: 0 10px;
}

#post-468223 .articleBody {
	margin: 0;
}

#post-468221 .entry-content {
	padding: 0 10px;
}

#post-468221 .articleBody {
	margin: 0;
}

#post-437973 .entry-content {
	padding: 0 10px;
}

#post-437973 .articleBody {
	margin: 0;
}

#post-430049 .entry-content {
	padding: 0 10px;
}

#post-430049 .articleBody {
	margin: 0;
}

#post-428529 .entry-content {
	padding: 0 10px;
}

#post-428529 .articleBody {
	margin: 0;
}

#post-428525 .entry-content {
	padding: 0 10px;
}

#post-428525 .articleBody {
	margin: 0;
}

#post-427652 .entry-content {
	padding: 0 10px;
}

#post-427652 .articleBody {
	margin: 0;
}

#post-427649 .entry-content {
	padding: 0 10px;
}

#post-427649 .articleBody {
	margin: 0;
}

#post-44463 .entry-content {
	padding: 0 10px;
}

#post-44463 .articleBody {
	margin: 0;
}

#post-38350 .entry-content {
	padding: 0 10px;
}

#post-38350 .articleBody {
	margin: 0;
}

#post-31224 .entry-content {
	padding: 0 10px;
}

#post-31224 .articleBody {
	margin: 0;
}

#post-15534 .entry-content {
	padding: 0 10px;
}

#post-15534 .articleBody {
	margin: 0;
}

#post-9578 .entry-content {
	padding: 0 10px;
}

#post-9578 .articleBody {
	margin: 0;
}

#post-7952 .entry-content {
	padding: 0 10px;
}

#post-7952 .articleBody {
	margin: 0;
}		</style>
		
	<script type="text/javascript">
		var is_user_logged_in = 0;
	</script>

</head>

<body class="post-template-default single single-post postid-552984 single-format-standard">

	<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-ML9LGVK" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->
	<div id='acm-ad-tag-lawrence_dfp_desktop_skin' style='width:1px; height:1px;'><script type='text/javascript'>googletag.cmd.push(function(e) { googletag.display('acm-ad-tag-lawrence_dfp_desktop_skin'); });</script></div><div id='acm-ad-tag-lawrence_dfp_desktop_interstitial' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function(e) { googletag.display('acm-ad-tag-lawrence_dfp_desktop_interstitial'); });</script></div><div id='acm-ad-tag-lawrence_dfp_desktop_outstream' style='width:4px; height:1px;'><script type='text/javascript'>googletag.cmd.push(function(e) { googletag.display('acm-ad-tag-lawrence_dfp_desktop_outstream'); });</script></div>
	
<div id="wrapper">

	
	<div class="sticky-header-ad-above-nav-extra-space"></div>
<div id="header-ad" class="  header-ad--above-nav sticky-header-ad-above-nav">
	<div id='acm-ad-tag-lawrence_dfp_desktop_top' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function(e) { googletag.display('acm-ad-tag-lawrence_dfp_desktop_top'); });</script></div></div>
<div class="sticky-header-ad-below-nav-extra-space"></div>

	<div class="wrapper-holder">

		<div
	class="branding "
	id="nav-branding"
>
	<span class="branding__logos">
					<a
				href="https://theclemsoninsider.com"
				title="The Clemson Insider"
				class="branding__logo-link "
			>
				<img
					src="https://theclemsoninsider.com/wp-content/uploads/sites/81/2017/10/tci.png"
					alt="The Clemson Insider"
					class="branding__logo"
					height="30"
								>
			</a>
		
			</span>

	
	<span class="branding__search ui-front">
		<form method="get" class="branding__search-form" action="https://theclemsoninsider.com" role="search">
			<input type="text" name="s" value="" placeholder="search The Clemson Insider" class="branding__search-input">
			<a class="branding__search-close"></a>
		</form>
	</span>

		<a class="branding__mobile"></a>
</div>
<header class="nav  ">
	<nav class="nav__wrap">
		<ul class="nav__menu">
			<li id="menu-item-75044" class="nav__item nav__item--home"><a href="/">Home</a></li>
<li id="menu-item-75043" class="nav__item nav__item--forums nav__item--parent"><a href="http://forums.theclemsoninsider.com/">Forums</a>
<ul class="sub-menu">
	<li id="menu-item-427683" class="nav__item nav__item--the-rock"><a href="http://forums.theclemsoninsider.com/forumdisplay.php?f=2">The Rock</a></li>
	<li id="menu-item-427684" class="nav__item nav__item--all-in-recruiting"><a href="http://forums.theclemsoninsider.com/forumdisplay.php?f=14">All In Recruiting</a></li>
	<li id="menu-item-427685" class="nav__item nav__item--tweet-that"><a href="http://forums.theclemsoninsider.com/forumdisplay.php?f=15">Tweet That</a></li>
	<li id="menu-item-427686" class="nav__item nav__item--joes-place"><a href="http://forums.theclemsoninsider.com/forumdisplay.php?f=11">Joe's Place</a></li>
</ul>
</li>
<li id="menu-item-75046" class="nav__item nav__item--football nav__item--parent"><a href="https://theclemsoninsider.com/category/football/">Football</a>
<ul class="sub-menu">
	<li id="menu-item-427478" class="nav__item nav__item--depth-tracker"><a href="https://theclemsoninsider.com/depth-tracker/">Depth Tracker</a></li>
	<li id="menu-item-427479" class="nav__item nav__item--football-roster"><a href="https://theclemsoninsider.com/football-roster/">Football Roster</a></li>
	<li id="menu-item-427480" class="nav__item nav__item--football-schedule"><a href="https://theclemsoninsider.com/football-schedule/">Football Schedule</a></li>
</ul>
</li>
<li id="menu-item-75047" class="nav__item nav__item--baseball nav__item--parent"><a href="https://theclemsoninsider.com/category/baseball/">Baseball</a>
<ul class="sub-menu">
	<li id="menu-item-427662" class="nav__item nav__item--2015-baseball-commits"><a href="https://theclemsoninsider.com/2015-baseball-commits/">2015 Baseball Commits</a></li>
	<li id="menu-item-428609" class="nav__item nav__item--2016-baseball-commits"><a href="https://theclemsoninsider.com/2016-baseball-commits/">2016 Baseball Commits</a></li>
	<li id="menu-item-428608" class="nav__item nav__item--2017-baseball-commits"><a href="https://theclemsoninsider.com/2017-baseball-commits/">2017 Baseball Commits</a></li>
	<li id="menu-item-498045" class="nav__item nav__item--2018-baseball-commits"><a href="https://theclemsoninsider.com/2018-baseball-commits/">2018 Baseball Commits</a></li>
	<li id="menu-item-498044" class="nav__item nav__item--2019-baseball-commits"><a href="https://theclemsoninsider.com/2019-baseball-commits/">2019 Baseball Commits</a></li>
	<li id="menu-item-498043" class="nav__item nav__item--2020-baseball-commits"><a href="https://theclemsoninsider.com/2020-baseball-commits/">2020 Baseball Commits</a></li>
	<li id="menu-item-498042" class="nav__item nav__item--2021-baseball-commits"><a href="https://theclemsoninsider.com/2021-baseball-commits/">2021 Baseball Commits</a></li>
	<li id="menu-item-427663" class="nav__item nav__item--baseball-schedule"><a href="https://theclemsoninsider.com/baseball-schedule/">Baseball Schedule</a></li>
	<li id="menu-item-427664" class="nav__item nav__item--baseball-roster"><a href="https://theclemsoninsider.com/baseball-roster-3/">Baseball Roster</a></li>
</ul>
</li>
<li id="menu-item-75048" class="nav__item nav__item--recruiting nav__item--parent"><a href="https://theclemsoninsider.com/category/recruiting/">Recruiting</a>
<ul class="sub-menu">
	<li id="menu-item-437979" class="nav__item nav__item--2017-football-commitments"><a href="https://theclemsoninsider.com/2017-football-recruits/">2017 Football Commitments</a></li>
	<li id="menu-item-468542" class="nav__item nav__item--2018-football-commitments"><a href="https://theclemsoninsider.com/2018-football-commitments/">2018 Football Commitments</a></li>
	<li id="menu-item-468541" class="nav__item nav__item--2019-football-commitments"><a href="https://theclemsoninsider.com/2019-football-commitments/">2019 Football Commitments</a></li>
	<li id="menu-item-499814" class="nav__item nav__item--2020-football-commitments"><a href="http://recruiting.theclemsoninsider.com/prospects/2020?status=commits">2020 Football Commitments</a></li>
	<li id="menu-item-523741" class="nav__item nav__item--2021-commitments"><a href="http://recruiting.theclemsoninsider.com/prospects/2021?status=commits">2021 Commitments</a></li>
	<li id="menu-item-514148" class="nav__item nav__item--football-recruits"><a href="http://recruiting.theclemsoninsider.com/prospects/2020">Football Recruits</a></li>
</ul>
</li>
<li id="menu-item-75049" class="nav__item nav__item--basketball nav__item--parent"><a href="https://theclemsoninsider.com/category/basketball/">Basketball</a>
<ul class="sub-menu">
	<li id="menu-item-427693" class="nav__item nav__item--basketball-roster"><a href="https://theclemsoninsider.com/basketball-roster/">Basketball Roster</a></li>
	<li id="menu-item-427692" class="nav__item nav__item--basketball-schedule"><a href="https://theclemsoninsider.com/basketball-schedule/">Basketball Schedule</a></li>
</ul>
</li>
<li id="menu-item-514147" class="nav__item nav__item--galleries"><a href="http://recruiting.theclemsoninsider.com/gallery">Galleries</a></li>
<li id="menu-item-75050" class="nav__item nav__item--olympic"><a href="https://theclemsoninsider.com/category/olympic/">Olympic</a></li>
<li id="menu-item-520576" class="nav__item nav__item--tcis-student-alumni"><a href="https://theclemsoninsider.com/tcis-alumni/">TCI's Student Alumni</a></li>
		</ul>
		<ul class="nav__social ">
			<li class="nav__item nav__item--social nav__item--facebook">
			<a href="https://www.facebook.com/theclemsoninsider" class="nav__item-link"></a>
		</li>
			<li class="nav__item nav__item--social nav__item--twitter">
			<a href="http://twitter.com/clemsoninsider" class="nav__item-link"></a>
		</li>
	</ul>
	</nav>
</header>

		
		<nav class="trending">
	<h3 class="trending__title">Popular Now</h3>

	<ul class="trending__list">
					<li class="
				trending__item
				trending__item--clemson							">

				<a href="https://theclemsoninsider.com/tag/clemson/" data-track="autotrending" class="trending__link">
					Clemson				</a>


			</li>
					<li class="
				trending__item
				trending__item--clemsontigers							">

				<a href="https://theclemsoninsider.com/tag/clemson-tigers/" data-track="autotrending" class="trending__link">
					Clemson Tigers				</a>


			</li>
					<li class="
				trending__item
				trending__item--clemsonfootball							">

				<a href="https://theclemsoninsider.com/tag/clemson-football/" data-track="autotrending" class="trending__link">
					Clemson football				</a>


			</li>
					<li class="
				trending__item
				trending__item--mattbockhorst							">

				<a href="https://theclemsoninsider.com/tag/matt-bockhorst/" data-track="autotrending" class="trending__link">
					Matt Bockhorst				</a>


			</li>
					<li class="
				trending__item
				trending__item--josephngata							">

				<a href="https://theclemsoninsider.com/tag/joseph-ngata/" data-track="autotrending" class="trending__link">
					Joseph Ngata				</a>


			</li>
					<li class="
				trending__item
				trending__item--trevorlawrence							">

				<a href="https://theclemsoninsider.com/tag/trevor-lawrence/" data-track="autotrending" class="trending__link">
					Trevor Lawrence				</a>


			</li>
					<li class="
				trending__item
				trending__item--clemsonathletics							">

				<a href="https://theclemsoninsider.com/tag/clemson-athletics/" data-track="autotrending" class="trending__link">
					Clemson Athletics				</a>


			</li>
					<li class="
				trending__item
				trending__item--ejwilliams							">

				<a href="https://theclemsoninsider.com/tag/e-j-williams/" data-track="autotrending" class="trending__link">
					E.J. Williams				</a>


			</li>
					<li class="
				trending__item
				trending__item--clemsonmensbasketball							">

				<a href="https://theclemsoninsider.com/tag/clemson-mens-basketball/" data-track="autotrending" class="trending__link">
					Clemson men&#039;s basketball				</a>


			</li>
					<li class="
				trending__item
				trending__item--travisetienne							">

				<a href="https://theclemsoninsider.com/tag/travis-etienne/" data-track="autotrending" class="trending__link">
					Travis Etienne				</a>


			</li>
			</ul>

</nav>

		<div id="main" class="site-main ">

			

<div id="primary" class="content-area">
	<div id="content" class="site-content" role="main">

		
		
			<article id="post-552984" class="post-552984 post type-post status-publish format-standard has-post-thumbnail hentry category-feature-2 category-football tag-clemson-football tag-darien-rencher tag-pitt-football" itemscope
				itemtype="http://schema.org/NewsArticle">

				<link itemprop="mainEntityofPage" href="https://theclemsoninsider.com/2020/11/28/rencher-ready-for-another-moment-in-his-clemson-journey/" />
<div itemprop="publisher" itemscope itemtype="https://www.schema.org/Organization">
	<div itemprop="logo" itemscope itemtype="https://www.schema.org/ImageObject">
		<link src="https://theclemsoninsider.com/wp-content/uploads/sites/81/2017/10/tci.png"/>
		<meta itemprop="url" content="https://theclemsoninsider.com/wp-content/uploads/sites/81/2017/10/tci.png">
	</div>
	<meta itemprop="name" content="The Clemson Insider">
</div>
<div class="article__title ">
	<h1 class="article__headline">Rencher ready for another moment in his Clemson journey</h1>

			<span itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
			<img width="1000" height="600" src="https://theclemsoninsider.com/wp-content/uploads/sites/81/2019/10/darien-rencher-1.jpg?w=100&amp;h=600&amp;crop=1&amp;h=60" class="article__image wp-post-image lazy-load" alt loading="lazy" data-lazy-src="https://theclemsoninsider.com/wp-content/uploads/sites/81/2019/10/darien-rencher-1.jpg?w=1000&amp;h=600&amp;crop=1"><noscript><img width="1000" height="600" src="https://theclemsoninsider.com/wp-content/uploads/sites/81/2019/10/darien-rencher-1.jpg?w=1000&amp;h=600&amp;crop=1" class="article__image wp-post-image" alt="" loading="lazy" /></noscript>			<meta itemprop="url" content="https://theclemsoninsider.com/wp-content/uploads/sites/81/2019/10/darien-rencher-1.jpg">
		</span>
		<cite class="article__source"></cite>
		<div class="article__gradient"></div>
	</div>
<h1 class="article__headline article__headline--mobile">Rencher ready for another moment in his Clemson journey</h1>

				<header class="entry-header  ">

					
<h2 class="cat-show">
	<a href="https://theclemsoninsider.com/category/feature-2/" class="" itemprop="articleSection">Feature</a></h2>

					
					<div id="headline">
						<h1 class="entry-title" itemprop="name headline">Rencher ready for another moment in his Clemson journey</h1>
											</div>

					
					
					<div class="meta-info single-headline" id="entry-byline">
						
<p>

	By <span itemprop="author" itemscope itemtype="http://schema.org/Person"><span itemprop="name"><a href="https://theclemsoninsider.com/author/abigail-angalet/" title="Posts by Abigail Angalet" class="author url fn" rel="author">Abigail Angalet</a></span></span> 
		<span class="post-date updated">November 28, 2020 6:32 am</span>

	
	
					<span class="author-twitter-follow-button">
				<a href="http://twitter.com/agangalet" class="twitter-follow-button" data-show-count="false">
					Follow					@agangalet				</a>
				<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>
			</span>
		
	</p>
					</div>

					<div id='acm-ad-tag-lawrence_dfp_mobile_sponsor_by_logo' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function(e) { googletag.display('acm-ad-tag-lawrence_dfp_mobile_sponsor_by_logo'); });</script></div>
				</header>

				
				
				
				
				<div id="content-container">
					<div class="entry-content normal-format">

						
						<div class="story-share-buttons sms">
	<div class="share-button share-count">
		<span class="icomoon icon-shares"></span>
		<span class="count">31</span>
		<span class="share-text">shares</span>
	</div>
	<div
		data-url="https://theclemsoninsider.com/2020/11/28/rencher-ready-for-another-moment-in-his-clemson-journey/"
		data-short-url=""
		data-track="storyfb"
		class="share-button share-facebook st-custom-button"
		id="share-facebook"
		data-network="facebook"
	>
		<span class="icomoon icon-facebook"></span>
		<span class="share-text">share</span>
	</div>
	<div
		data-url="https://theclemsoninsider.com/2020/11/28/rencher-ready-for-another-moment-in-his-clemson-journey/"
		data-short-url=""
		data-track="storytwitter"
		class="share-button share-twitter st-custom-button"
		id="share-twitter"
		data-network="twitter"
		data-username="clemsoninsider"
	>
		<span class="icomoon icon-twitter"></span>
		<span class="share-text">tweet</span>
	</div>
	<div
		data-url="https://theclemsoninsider.com/2020/11/28/rencher-ready-for-another-moment-in-his-clemson-journey/"
		data-short-url=""
		data-track="storypinterest"
		class="share-button share-pinterest st-custom-button"
		id="share-pinterest"
		data-network="pinterest"
		data-username=""
	>
		<span class="icomoon icon-pinterest"></span>
		<span class="share-text">pin</span>
	</div>
	<div
		data-url="https://theclemsoninsider.com/2020/11/28/rencher-ready-for-another-moment-in-his-clemson-journey/"
		data-short-url=""
		data-track="storysms"
		class="share-button share-sms st-custom-button"
		id="share-sms"
		data-network="sms"
	>
		<span class="icomoon icon-sms"></span>
		<span class="share-text">sms</span>
	</div>
	<div
		data-url="https://theclemsoninsider.com/2020/11/28/rencher-ready-for-another-moment-in-his-clemson-journey/"
		data-short-url=""
		data-track="storywhatsapp"
		class="share-button share-whatsapp st-custom-button"
		id="share-whatsapp"
		data-network="whatsapp"
	>
		<span class="icomoon icon-whatsapp"></span>
		<span class="share-text">send</span>
	</div>

			<div
			data-url="https://theclemsoninsider.com/2020/11/28/rencher-ready-for-another-moment-in-his-clemson-journey/"
			data-short-url=""
			data-track="storyemail"
			class="share-button share-email st-custom-button"
			id="share-email"
			data-network="email"
			data-message=""
		>
				<span class="icomoon icon-email"></span>
			<span class="share-text">email</span>
		</div>
</div>

						
						<div class="article__author">
	<p>
		By 		<span itemprop="author" itemscope itemtype="http://schema.org/Person"><span itemprop="name"><a href="https://theclemsoninsider.com/author/abigail-angalet/" title="Posts by Abigail Angalet" class="author url fn" rel="author">Abigail Angalet</a></span></span> |
		<span itemprop="datePublished" content="2020-11-28T06:32:40-05:00">
			November 28, 2020 6:32 am		</span>
		<span class="article__author__widgets">
										<span class="author-twitter-follow-button author__twitter">
	<a href="http://twitter.com/agangalet" class="twitter-follow-button" data-show-count="false">
		Follow @agangalet	</a>
	<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>
</span>
					</span>
	</p>

	</div>


						
						<div class="articleBody" itemprop="articleBody"><img width="300" height="195" src="https://theclemsoninsider.com/wp-content/uploads/sites/81/2019/10/darien-rencher-1.jpg?w=30&amp;h=19" class="alignleft size-medium wp-post-image lazy-load" alt loading="lazy" data-lazy-src="https://theclemsoninsider.com/wp-content/uploads/sites/81/2019/10/darien-rencher-1.jpg?w=300" data-lazy-srcset="https://theclemsoninsider.com/wp-content/uploads/sites/81/2019/10/darien-rencher-1.jpg 1577w, https://theclemsoninsider.com/wp-content/uploads/sites/81/2019/10/darien-rencher-1.jpg?resize=300,195 300w, https://theclemsoninsider.com/wp-content/uploads/sites/81/2019/10/darien-rencher-1.jpg?resize=768,499 768w, https://theclemsoninsider.com/wp-content/uploads/sites/81/2019/10/darien-rencher-1.jpg?resize=1024,665 1024w, https://theclemsoninsider.com/wp-content/uploads/sites/81/2019/10/darien-rencher-1.jpg?resize=1536,997 1536w, https://theclemsoninsider.com/wp-content/uploads/sites/81/2019/10/darien-rencher-1.jpg?resize=480,312 480w" data-lazy-sizes="(max-width: 300px) 100vw, 300px"><noscript><img width="300" height="195" src="https://theclemsoninsider.com/wp-content/uploads/sites/81/2019/10/darien-rencher-1.jpg?w=300" class="alignleft size-medium wp-post-image" alt="" loading="lazy" srcset="https://theclemsoninsider.com/wp-content/uploads/sites/81/2019/10/darien-rencher-1.jpg 1577w, https://theclemsoninsider.com/wp-content/uploads/sites/81/2019/10/darien-rencher-1.jpg?resize=300,195 300w, https://theclemsoninsider.com/wp-content/uploads/sites/81/2019/10/darien-rencher-1.jpg?resize=768,499 768w, https://theclemsoninsider.com/wp-content/uploads/sites/81/2019/10/darien-rencher-1.jpg?resize=1024,665 1024w, https://theclemsoninsider.com/wp-content/uploads/sites/81/2019/10/darien-rencher-1.jpg?resize=1536,997 1536w, https://theclemsoninsider.com/wp-content/uploads/sites/81/2019/10/darien-rencher-1.jpg?resize=480,312 480w" sizes="(max-width: 300px) 100vw, 300px" /></noscript><p><span style="font-weight: 400;">Saturday will certainly be a special day for many Clemson seniors including Darien Rencher.</span></p>
<p><span style="font-weight: 400;">Saturday&#8217;s home finale against Pittsburgh may be the last time the senior running back goes down the hill as a player. </span></p>
<div class="the-scores-widget-wrapper"><blockquote class="scores-widget" data-widget-id="050315ce-1a83-445f-a59b-4fd7fe7ff4a5" data-token="1122E733A7174398AD9905B8FADA72FD"></blockquote><script src="https://widgets.thescore.com/js/widgets/platform.js"></script></div>
<p><span style="font-weight: 400;">Rencher has emerged as one of the Tigers key leaders over the past few season but missed last week after testing positive for COVID-19. This season has looked a lot different than expected but the senior wouldn’t trade his experience at Clemson for the world.</span></p>
<p><span style="font-weight: 400;">“You never unintentionally end up somewhere, so I definitely feel like I envisioned some of this, but then again, I didn’t envision it to play out the way it did,” Rencher said. </span></p>
<p>He entered the program as a walk-on freshman year and thought he may just spend his time at Clemson on the scout team with defensive coordinator Brent Venables, affectionately known as Jimmy Green Beans. But Rencher believed his dream of playing for the Tigers would be realized.</p>
<p><span style="font-weight: 400;">“I didn’t really understand how it was going to manifest itself I just kind of trusted the steps that were put in front of me cause I didn’t know I was going to be with Jimmy Green Beans on scout team, like I didn’t know anything,” he said.</span></p>
<p><span style="font-weight: 400;">“I just showed up here, I had a dream, I was eager, I was driven, and I had some faith and I believed in what this program said it was about and that it would give people opportunities if people worked for it.”</span></p>
<p><span style="font-weight: 400;">While the senior wasn’t quite ready to share what the future might hold for his football career after this season, he did share some of his favorite moments he’s shared with his teammates both on and off the field since his start as a walk-on in 2016. </span></p>
<p><span style="font-weight: 400;">For Rencher, the legacy he hopes to leave behind off the field is far more important than any number of yards or receptions on the field.</span></p>
<p><span style="font-weight: 400;">“I think the moments during this off-season were in the top five moments of my career along with winning national championships and getting put on scholarship like all those things,” he said. “But hopefully, holistically people remember that I loved people, I was a light, and that I was just Darien and Darien was unique.”</span></p>
<p><span style="font-weight: 400;">Rencher has had his fair share of special moments in the Clemson uniform like two national championships under his belt and stepping up as a key leader for the Tigers. </span></p>
<p><span style="font-weight: 400;">Now, the running back is looking to have what could be one last memorable game day playing alongside his teammates at home. A</span><span style="font-weight: 400;"> win on Saturday, would make Clemson’s senior class the first in program history to go undefeated at Memorial Stadium since its opening in 1942.</span></p>
<p><span style="font-weight: 400;">The Tigers host Pitt for Senior Day on Saturday with kickoff slated for 3:30 pm, on ABC.</span></p></div>

						<div id='acm-ad-tag-lawrence_dfp_desktop_arkadium' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function(e) { googletag.display('acm-ad-tag-lawrence_dfp_desktop_arkadium'); });</script></div>
						
						
						
						<p class="post-tags post-tags--hide"><a href="https://theclemsoninsider.com/tag/clemson-football/" rel="tag">Clemson football</a>, <a href="https://theclemsoninsider.com/tag/darien-rencher/" rel="tag">Darien Rencher</a>, <a href="https://theclemsoninsider.com/tag/pitt-football/" rel="tag">Pitt football</a>, <a href="https://theclemsoninsider.com/category/feature-2/" rel="category tag">Feature</a>, <a href="https://theclemsoninsider.com/category/football/" rel="category tag">Football</a></p>
						<div class="story-share-buttons sms">
	<div class="share-button share-count">
		<span class="icomoon icon-shares"></span>
		<span class="count">31</span>
		<span class="share-text">shares</span>
	</div>
	<div
		data-url="https://theclemsoninsider.com/2020/11/28/rencher-ready-for-another-moment-in-his-clemson-journey/"
		data-short-url=""
		data-track="storyfb"
		class="share-button share-facebook st-custom-button"
		id="share-facebook"
		data-network="facebook"
	>
		<span class="icomoon icon-facebook"></span>
		<span class="share-text">share</span>
	</div>
	<div
		data-url="https://theclemsoninsider.com/2020/11/28/rencher-ready-for-another-moment-in-his-clemson-journey/"
		data-short-url=""
		data-track="storytwitter"
		class="share-button share-twitter st-custom-button"
		id="share-twitter"
		data-network="twitter"
		data-username="clemsoninsider"
	>
		<span class="icomoon icon-twitter"></span>
		<span class="share-text">tweet</span>
	</div>
	<div
		data-url="https://theclemsoninsider.com/2020/11/28/rencher-ready-for-another-moment-in-his-clemson-journey/"
		data-short-url=""
		data-track="storypinterest"
		class="share-button share-pinterest st-custom-button"
		id="share-pinterest"
		data-network="pinterest"
		data-username=""
	>
		<span class="icomoon icon-pinterest"></span>
		<span class="share-text">pin</span>
	</div>
	<div
		data-url="https://theclemsoninsider.com/2020/11/28/rencher-ready-for-another-moment-in-his-clemson-journey/"
		data-short-url=""
		data-track="storysms"
		class="share-button share-sms st-custom-button"
		id="share-sms"
		data-network="sms"
	>
		<span class="icomoon icon-sms"></span>
		<span class="share-text">sms</span>
	</div>
	<div
		data-url="https://theclemsoninsider.com/2020/11/28/rencher-ready-for-another-moment-in-his-clemson-journey/"
		data-short-url=""
		data-track="storywhatsapp"
		class="share-button share-whatsapp st-custom-button"
		id="share-whatsapp"
		data-network="whatsapp"
	>
		<span class="icomoon icon-whatsapp"></span>
		<span class="share-text">send</span>
	</div>

			<div
			data-url="https://theclemsoninsider.com/2020/11/28/rencher-ready-for-another-moment-in-his-clemson-journey/"
			data-short-url=""
			data-track="storyemail"
			class="share-button share-email st-custom-button"
			id="share-email"
			data-network="email"
			data-message=""
		>
				<span class="icomoon icon-email"></span>
			<span class="share-text">email</span>
		</div>
</div>
<div class="after-article widget_text">			<div class="textwidget"><div class="veeseoRA2VW"></div></div>
		</div>					</div><!-- .entry-content -->
				</div><!-- #content-container -->

				
			</article><!-- #post-## -->

		
		<div class="container divider"></div>
<div class="container single-related">

		<div class="heading-small">
		<h2>More <span>TCI</span></h2>
	</div>
	
	<div class="holder-column">
		<div class="column">
			<article class="block block-single-related">
	<a href="https://theclemsoninsider.com/2020/11/27/spray-reaches-career-milestone-as-tigers-topple-blue-hose/"
		data-track="featuredstories more-related-1"
		title="Spray Reaches Career Milestone as Tigers Topple Blue Hose"
		class="link fixed-height-img-holder responsiveshort"
		rel="nofollow"
					style="background-image: url('https://theclemsoninsider.com/wp-content/uploads/sites/81/2020/11/Spray-.jpg?w=295&#038;h=231&#038;crop=1');"
				itemprop="url">

					<img src="https://theclemsoninsider.com/wp-content/uploads/sites/81/2020/11/Spray-.jpg?w=295&#038;h=231&#038;crop=1" width="206" height="165" alt="Spray Reaches Career Milestone as Tigers Topple Blue Hose" itemprop="image">
		
		<span class="ie-overlay-hack"></span>

		
		
			</a>

	<div class="text-block">

		<span class="block__shares">64 shares</span><span class="block__time block__time--mobile">11hr ago</span>
		<h2><a href="https://theclemsoninsider.com/category/feature-2/" class="category" itemprop="articleSection">Feature</a></h2>

		<p>
			<a data-track="featuredstories more-related-1" href="https://theclemsoninsider.com/2020/11/27/spray-reaches-career-milestone-as-tigers-topple-blue-hose/"
				title="Spray Reaches Career Milestone as Tigers Topple Blue Hose" itemprop="url">
				Spray Reaches Career Milestone as Tigers Topple Blue Hose			</a>
		</p>

	</div>
</article>
<article class="block block-single-related">
	<a href="https://theclemsoninsider.com/2020/11/27/turner-poised-for-possible-final-game-at-death-valley/"
		data-track="featuredstories more-related-2"
		title="Turner poised for possible final game at Death Valley"
		class="link fixed-height-img-holder responsiveshort"
		rel="nofollow"
					style="background-image: url('https://theclemsoninsider.com/wp-content/uploads/sites/81/2020/11/Nolan-Turner.jpg?w=295&#038;h=231&#038;crop=1');"
				itemprop="url">

					<img src="https://theclemsoninsider.com/wp-content/uploads/sites/81/2020/11/Nolan-Turner.jpg?w=295&#038;h=231&#038;crop=1" width="206" height="165" alt="Turner poised for possible final game at Death Valley" itemprop="image">
		
		<span class="ie-overlay-hack"></span>

		
		
			</a>

	<div class="text-block">

		<span class="block__shares">195 shares</span><span class="block__time block__time--mobile">12hr ago</span>
		<h2><a href="https://theclemsoninsider.com/category/feature-2/" class="category" itemprop="articleSection">Feature</a></h2>

		<p>
			<a data-track="featuredstories more-related-2" href="https://theclemsoninsider.com/2020/11/27/turner-poised-for-possible-final-game-at-death-valley/"
				title="Turner poised for possible final game at Death Valley" itemprop="url">
				Turner poised for possible final game at Death Valley			</a>
		</p>

	</div>
</article>
<article class="block block-single-related">
	<a href="https://theclemsoninsider.com/2020/11/27/venables-clemson-defense-not-overlooking-pickett/"
		data-track="featuredstories more-related-3"
		title="Venables, Clemson defense not overlooking Pickett"
		class="link fixed-height-img-holder responsiveshort"
		rel="nofollow"
					style="background-image: url('https://theclemsoninsider.com/wp-content/uploads/sites/81/2020/11/Kenny-Pickett.jpg?w=295&#038;h=231&#038;crop=1');"
				itemprop="url">

					<img src="https://theclemsoninsider.com/wp-content/uploads/sites/81/2020/11/Kenny-Pickett.jpg?w=295&#038;h=231&#038;crop=1" width="206" height="165" alt="Venables, Clemson defense not overlooking Pickett" itemprop="image">
		
		<span class="ie-overlay-hack"></span>

		
		
			</a>

	<div class="text-block">

		<span class="block__shares">88 shares</span><span class="block__time block__time--mobile">1d ago</span>
		<h2><a href="https://theclemsoninsider.com/category/feature-2/" class="category" itemprop="articleSection">Feature</a></h2>

		<p>
			<a data-track="featuredstories more-related-3" href="https://theclemsoninsider.com/2020/11/27/venables-clemson-defense-not-overlooking-pickett/"
				title="Venables, Clemson defense not overlooking Pickett" itemprop="url">
				Venables, Clemson defense not overlooking Pickett			</a>
		</p>

	</div>
</article>

		</div>
	</div>
</div>
<div class="container single-related single-related--zergnet is-wasabi" id="single-related-zergnet-lawrence">
		<div class="heading-small"><h2>From <span>The Web</span></h2></div>
		<div id="zergnet-widget-82059" class="zergnet-wrapper"></div>
	</div><div class="container column container--stories">
	<div class="heading-small">
		<h2>Latest</h2>
	</div>
	<div id='acm-ad-tag-lawrence_dfp_desktop_native' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function(e) { googletag.display('acm-ad-tag-lawrence_dfp_desktop_native'); });</script></div>
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="mostrecent"
						href="https://theclemsoninsider.com/2020/11/28/who-has-the-edge-etiennes-last-day-in-the-valley/"
						title="Who has the edge? Etienne’s last day in the Valley"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://theclemsoninsider.com/wp-content/uploads/sites/81/2020/10/Travis-Etienne-3-3.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://theclemsoninsider.com/wp-content/uploads/sites/81/2020/10/Travis-Etienne-3-3.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Who has the edge? Etienne’s last day in the Valley" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://theclemsoninsider.com/2020/11/28/who-has-the-edge-etiennes-last-day-in-the-valley/';">
	<div class="reply-block">
		<a
			data-track="mostrecent"
			href="https://theclemsoninsider.com/2020/11/28/who-has-the-edge-etiennes-last-day-in-the-valley/"
			title="Who has the edge? Etienne’s last day in the Valley"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>30</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				23m			</div>

			<div class="content  ">
				
				<h3>
										<a
						data-track="mostrecent"
						href="https://theclemsoninsider.com/2020/11/28/who-has-the-edge-etiennes-last-day-in-the-valley/"
						title="Who has the edge? Etienne’s last day in the Valley"
						itemprop="url" 						>
							Who has the edge? Etienne’s last day in the Valley					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
						<a href="https://theclemsoninsider.com/category/football/" class="category" itemprop="articleSection">Football</a><span class="dot">&middot;</span>						<span class="time">November 28, 2020 7:43 am </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://theclemsoninsider.com/author/will-vandervort/" title="Posts by Will Vandervort" class="author url fn" rel="author">Will Vandervort</a>													</span>
					</p>
				</footer>

				<p>Travis Etienne will run down the hill one final time for third-ranked Clemson when the Tigers host Pitt today on Senior Day at Death Valley. Etienne will leave Death Valley as the greatest to run the football at (&#8230;)</p>

				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="mostrecent"
						href="https://theclemsoninsider.com/2020/11/27/spray-reaches-career-milestone-as-tigers-topple-blue-hose/"
						title="Spray Reaches Career Milestone as Tigers Topple Blue Hose"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://theclemsoninsider.com/wp-content/uploads/sites/81/2020/11/Spray-.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://theclemsoninsider.com/wp-content/uploads/sites/81/2020/11/Spray-.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Spray Reaches Career Milestone as Tigers Topple Blue Hose" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://theclemsoninsider.com/2020/11/27/spray-reaches-career-milestone-as-tigers-topple-blue-hose/';">
	<div class="reply-block">
		<a
			data-track="mostrecent"
			href="https://theclemsoninsider.com/2020/11/27/spray-reaches-career-milestone-as-tigers-topple-blue-hose/"
			title="Spray Reaches Career Milestone as Tigers Topple Blue Hose"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>64</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				11hr			</div>

			<div class="content  ">
				
				<h3>
										<a
						data-track="mostrecent"
						href="https://theclemsoninsider.com/2020/11/27/spray-reaches-career-milestone-as-tigers-topple-blue-hose/"
						title="Spray Reaches Career Milestone as Tigers Topple Blue Hose"
						itemprop="url" 						>
							Spray Reaches Career Milestone as Tigers Topple Blue Hose					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
						<a href="https://theclemsoninsider.com/category/feature-2/" class="category" itemprop="articleSection">Feature</a><span class="dot">&middot;</span>						<span class="time">November 27, 2020 8:14 pm </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://theclemsoninsider.com/author/staff-reports/" title="Posts by Staff Reports" class="author url fn" rel="author">Staff Reports</a>													</span>
					</p>
				</footer>

				<p>In a game that saw Clemson sharpshooter Kendall Spray reach a momentous milestone, the Tigers trounced Presbyterian College in runaway fashion. The Tigers roared past the Blue Hose at Littlejohn (&#8230;)</p>

				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="mostrecent"
						href="https://theclemsoninsider.com/2020/11/27/turner-poised-for-possible-final-game-at-death-valley/"
						title="Turner poised for possible final game at Death Valley"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://theclemsoninsider.com/wp-content/uploads/sites/81/2020/11/Nolan-Turner.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://theclemsoninsider.com/wp-content/uploads/sites/81/2020/11/Nolan-Turner.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Turner poised for possible final game at Death Valley" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://theclemsoninsider.com/2020/11/27/turner-poised-for-possible-final-game-at-death-valley/';">
	<div class="reply-block">
		<a
			data-track="mostrecent"
			href="https://theclemsoninsider.com/2020/11/27/turner-poised-for-possible-final-game-at-death-valley/"
			title="Turner poised for possible final game at Death Valley"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>195</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				12hr			</div>

			<div class="content  ">
				
				<h3>
										<a
						data-track="mostrecent"
						href="https://theclemsoninsider.com/2020/11/27/turner-poised-for-possible-final-game-at-death-valley/"
						title="Turner poised for possible final game at Death Valley"
						itemprop="url" 						>
							Turner poised for possible final game at Death Valley					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
						<a href="https://theclemsoninsider.com/category/feature-2/" class="category" itemprop="articleSection">Feature</a><span class="dot">&middot;</span>						<span class="time">November 27, 2020 7:55 pm </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://theclemsoninsider.com/author/taylor-farmer/" title="Posts by Taylor Farmer" class="author url fn" rel="author">Taylor Farmer</a>													</span>
					</p>
				</footer>

				<p>Nolan Turner plays what might be his final game at Death Valley on Saturday as third-ranked Clemson hosts Pittsburgh. After a last minute postponement last weekend at Florida State, the Tigers have not played (&#8230;)</p>

				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="mostrecent"
						href="https://theclemsoninsider.com/2020/11/27/countdown-to-kickoff-finally-tigers-are-getting-back-on-the-field/"
						title="Countdown to Kickoff: Finally, Tigers are getting back on the field"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://theclemsoninsider.com/wp-content/uploads/sites/81/2018/12/isaiah-simmons.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://theclemsoninsider.com/wp-content/uploads/sites/81/2018/12/isaiah-simmons.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Countdown to Kickoff: Finally, Tigers are getting back on the field" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://theclemsoninsider.com/2020/11/27/countdown-to-kickoff-finally-tigers-are-getting-back-on-the-field/';">
	<div class="reply-block">
		<a
			data-track="mostrecent"
			href="https://theclemsoninsider.com/2020/11/27/countdown-to-kickoff-finally-tigers-are-getting-back-on-the-field/"
			title="Countdown to Kickoff: Finally, Tigers are getting back on the field"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>54</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				12hr			</div>

			<div class="content  ">
				
				<h3>
										<a
						data-track="mostrecent"
						href="https://theclemsoninsider.com/2020/11/27/countdown-to-kickoff-finally-tigers-are-getting-back-on-the-field/"
						title="Countdown to Kickoff: Finally, Tigers are getting back on the field"
						itemprop="url" 						>
							Countdown to Kickoff: Finally, Tigers are getting back on the field					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
						<a href="https://theclemsoninsider.com/category/football/" class="category" itemprop="articleSection">Football</a><span class="dot">&middot;</span>						<span class="time">November 27, 2020 7:09 pm </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://theclemsoninsider.com/author/will-vandervort/" title="Posts by Will Vandervort" class="author url fn" rel="author">Will Vandervort</a>													</span>
					</p>
				</footer>

				<p>Saturday will mark the first time in 21 days No. 3 Clemson will play a football game when it hosts Pittsburgh at 3:30 p.m., at Death Valley on Senior Day and Military Appreciation Day. The 21-day layoff is (&#8230;)</p>

				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="mostrecent"
						href="https://theclemsoninsider.com/2020/11/27/clemson-athletics-latest-covid-19-report-2/"
						title="Clemson Athletics&#039; latest COVID-19 report"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://theclemsoninsider.com/wp-content/uploads/sites/81/2020/10/Clemson-players-and-helmets.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://theclemsoninsider.com/wp-content/uploads/sites/81/2020/10/Clemson-players-and-helmets.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Clemson Athletics&#039; latest COVID-19 report" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://theclemsoninsider.com/2020/11/27/clemson-athletics-latest-covid-19-report-2/';">
	<div class="reply-block">
		<a
			data-track="mostrecent"
			href="https://theclemsoninsider.com/2020/11/27/clemson-athletics-latest-covid-19-report-2/"
			title="Clemson Athletics&#039; latest COVID-19 report"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>302</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				16hr			</div>

			<div class="content  ">
				
				<h3>
										<a
						data-track="mostrecent"
						href="https://theclemsoninsider.com/2020/11/27/clemson-athletics-latest-covid-19-report-2/"
						title="Clemson Athletics&#039; latest COVID-19 report"
						itemprop="url" 						>
							Clemson Athletics&#039; latest COVID-19 report					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
						<a href="https://theclemsoninsider.com/category/baseball/" class="category" itemprop="articleSection">Baseball</a><span class="dot">&middot;</span>						<span class="time">November 27, 2020 4:01 pm </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://theclemsoninsider.com/author/staff-reports/" title="Posts by Staff Reports" class="author url fn" rel="author">Staff Reports</a>													</span>
					</p>
				</footer>

				<p>Clemson Athletics completed 1,277 COVID-19 PCR tests on student-athletes and staff from Nov. 20 to Nov. 26. A total of ten individuals tested positive, including eight student-athletes and two (&#8230;)</p>

				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="mostrecent"
						href="https://theclemsoninsider.com/2020/11/27/pitt-coach-clemson-gives-you-a-bunch-of-problems/"
						title="Pitt coach: &#039;Clemson gives you a bunch of problems&#039;"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://theclemsoninsider.com/wp-content/uploads/sites/81/2020/10/Trevor-Lawrence-4.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://theclemsoninsider.com/wp-content/uploads/sites/81/2020/10/Trevor-Lawrence-4.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Pitt coach: &#039;Clemson gives you a bunch of problems&#039;" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://theclemsoninsider.com/2020/11/27/pitt-coach-clemson-gives-you-a-bunch-of-problems/';">
	<div class="reply-block">
		<a
			data-track="mostrecent"
			href="https://theclemsoninsider.com/2020/11/27/pitt-coach-clemson-gives-you-a-bunch-of-problems/"
			title="Pitt coach: &#039;Clemson gives you a bunch of problems&#039;"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>62</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				16hr			</div>

			<div class="content  ">
				
				<h3>
										<a
						data-track="mostrecent"
						href="https://theclemsoninsider.com/2020/11/27/pitt-coach-clemson-gives-you-a-bunch-of-problems/"
						title="Pitt coach: &#039;Clemson gives you a bunch of problems&#039;"
						itemprop="url" 						>
							Pitt coach: &#039;Clemson gives you a bunch of problems&#039;					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
						<a href="https://theclemsoninsider.com/category/football/" class="category" itemprop="articleSection">Football</a><span class="dot">&middot;</span>						<span class="time">November 27, 2020 3:20 pm </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://theclemsoninsider.com/author/alex-turri/" title="Posts by Alex Turri" class="author url fn" rel="author">Alex Turri</a>													</span>
					</p>
				</footer>

				<p>As the third-ranked Clemson Tigers prepare for an ACC battle with Pittsburgh this weekend, the Panthers are doing the same up North. Recent history between the two programs has been interesting and (&#8230;)</p>

				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="mostrecent"
						href="https://theclemsoninsider.com/2020/11/27/clemson-wideout-to-honor-fallen-father-on-military-appreciation-day/"
						title="Clemson wideout to honor fallen father on Military Appreciation Day"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://theclemsoninsider.com/wp-content/uploads/sites/81/2020/11/E.J.-Williams-1.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://theclemsoninsider.com/wp-content/uploads/sites/81/2020/11/E.J.-Williams-1.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Clemson wideout to honor fallen father on Military Appreciation Day" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://theclemsoninsider.com/2020/11/27/clemson-wideout-to-honor-fallen-father-on-military-appreciation-day/';">
	<div class="reply-block">
		<a
			data-track="mostrecent"
			href="https://theclemsoninsider.com/2020/11/27/clemson-wideout-to-honor-fallen-father-on-military-appreciation-day/"
			title="Clemson wideout to honor fallen father on Military Appreciation Day"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>146</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				17hr			</div>

			<div class="content  ">
				
				<h3>
										<a
						data-track="mostrecent"
						href="https://theclemsoninsider.com/2020/11/27/clemson-wideout-to-honor-fallen-father-on-military-appreciation-day/"
						title="Clemson wideout to honor fallen father on Military Appreciation Day"
						itemprop="url" 						>
							Clemson wideout to honor fallen father on Military Appreciation Day					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
						<a href="https://theclemsoninsider.com/category/football/" class="category" itemprop="articleSection">Football</a><span class="dot">&middot;</span>						<span class="time">November 27, 2020 2:24 pm </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://theclemsoninsider.com/author/will-vandervort/" title="Posts by Will Vandervort" class="author url fn" rel="author">Will Vandervort</a>													</span>
					</p>
				</footer>

				<p>With wide receivers Joseph Ngata and Frank Ladson out for Saturday’s home finale against Pittsburgh, Clemson freshman E.J. Williams could potentially be making his first start for the Tigers. By itself, that (&#8230;)</p>

				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="mostrecent"
						href="https://theclemsoninsider.com/2020/11/27/2021-texas-corner-would-be-mind-blown-if-clemson-offers/"
						title="2021 Texas corner would be ‘mind-blown’ if Clemson offers"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://theclemsoninsider.com/wp-content/uploads/sites/81/2020/11/Marvin-Covington-2.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://theclemsoninsider.com/wp-content/uploads/sites/81/2020/11/Marvin-Covington-2.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="2021 Texas corner would be ‘mind-blown’ if Clemson offers" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://theclemsoninsider.com/2020/11/27/2021-texas-corner-would-be-mind-blown-if-clemson-offers/';">
	<div class="reply-block">
		<a
			data-track="mostrecent"
			href="https://theclemsoninsider.com/2020/11/27/2021-texas-corner-would-be-mind-blown-if-clemson-offers/"
			title="2021 Texas corner would be ‘mind-blown’ if Clemson offers"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>75</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				18hr			</div>

			<div class="content  ">
				
				<h3>
										<a
						data-track="mostrecent"
						href="https://theclemsoninsider.com/2020/11/27/2021-texas-corner-would-be-mind-blown-if-clemson-offers/"
						title="2021 Texas corner would be ‘mind-blown’ if Clemson offers"
						itemprop="url" 						>
							2021 Texas corner would be ‘mind-blown’ if Clemson offers					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
						<a href="https://theclemsoninsider.com/category/hero/" class="category" itemprop="articleSection">Hero</a><span class="dot">&middot;</span>						<span class="time">November 27, 2020 1:12 pm </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://theclemsoninsider.com/author/gavin-oliver/" title="Posts by Gavin Oliver" class="author url fn" rel="author">Gavin Oliver</a>													</span>
					</p>
				</footer>

				<p>In late October, Mansfield (Texas) Lake Ridge cornerback Marvin Covington received his first – and long-awaited – scholarship offer courtesy of Miami. Since then, the class of 2021 prospect has (&#8230;)</p>

				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="mostrecent"
						href="https://theclemsoninsider.com/2020/11/27/lawrences-fondest-memory-of-playing-at-death-valley-is-not-what-you-think/"
						title="Lawrence’s fondest memory of playing at Death Valley is not what you think"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://theclemsoninsider.com/wp-content/uploads/sites/81/2019/11/trevor-lawrence-4.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://theclemsoninsider.com/wp-content/uploads/sites/81/2019/11/trevor-lawrence-4.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Lawrence’s fondest memory of playing at Death Valley is not what you think" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://theclemsoninsider.com/2020/11/27/lawrences-fondest-memory-of-playing-at-death-valley-is-not-what-you-think/';">
	<div class="reply-block">
		<a
			data-track="mostrecent"
			href="https://theclemsoninsider.com/2020/11/27/lawrences-fondest-memory-of-playing-at-death-valley-is-not-what-you-think/"
			title="Lawrence’s fondest memory of playing at Death Valley is not what you think"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>1.2k</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				20hr			</div>

			<div class="content  ">
				
				<h3>
										<a
						data-track="mostrecent"
						href="https://theclemsoninsider.com/2020/11/27/lawrences-fondest-memory-of-playing-at-death-valley-is-not-what-you-think/"
						title="Lawrence’s fondest memory of playing at Death Valley is not what you think"
						itemprop="url" 						>
							Lawrence’s fondest memory of playing at Death Valley is not what you think					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
						<a href="https://theclemsoninsider.com/category/football/" class="category" itemprop="articleSection">Football</a><span class="dot">&middot;</span>						<span class="time">November 27, 2020 11:55 am </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://theclemsoninsider.com/author/will-vandervort/" title="Posts by Will Vandervort" class="author url fn" rel="author">Will Vandervort</a>													</span>
					</p>
				</footer>

				<p>It was not his stare down of the South Carolina bench after throwing a touchdown pass in Clemson’s win over its rival in 2018.  It was not his first 300-yard passing performance in a rout of No. 16 NC State (&#8230;)</p>

				
				
			</div>
		</article>
	
		<article class="block big  ">

			
				<div class="img-holder none light">
					<a
						data-track="mostrecent"
						href="https://theclemsoninsider.com/2020/11/27/two-minute-drill-lawrence-on-emotional-senior-day/"
						title="Two-Minute Drill: Lawrence on emotional Senior Day"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://theclemsoninsider.com/wp-content/uploads/sites/81/2020/10/LawrencePostgame.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://theclemsoninsider.com/wp-content/uploads/sites/81/2020/10/LawrencePostgame.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Two-Minute Drill: Lawrence on emotional Senior Day" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='https://theclemsoninsider.com/2020/11/27/two-minute-drill-lawrence-on-emotional-senior-day/';">
	<div class="reply-block">
		<a
			data-track="mostrecent"
			href="https://theclemsoninsider.com/2020/11/27/two-minute-drill-lawrence-on-emotional-senior-day/"
			title="Two-Minute Drill: Lawrence on emotional Senior Day"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>73</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				21hr			</div>

			<div class="content  ">
				
				<h3>
										<a
						data-track="mostrecent"
						href="https://theclemsoninsider.com/2020/11/27/two-minute-drill-lawrence-on-emotional-senior-day/"
						title="Two-Minute Drill: Lawrence on emotional Senior Day"
						itemprop="url" 						>
							Two-Minute Drill: Lawrence on emotional Senior Day					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
						<a href="https://theclemsoninsider.com/category/football/" class="category" itemprop="articleSection">Football</a><span class="dot">&middot;</span>						<span class="time">November 27, 2020 10:18 am </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							By: 							<a href="https://theclemsoninsider.com/author/bart-boatwright/" title="Posts by Bart Boatwright" class="author url fn" rel="author">Bart Boatwright</a>													</span>
					</p>
				</footer>

				<p>Saturday will be an emotional day for Clemson quarterback Trevor Lawrence as he runs down the Hill for perhaps the final time and plays his last game at Death Valley when No. 3 Clemson takes on Pitt at 3:30 (&#8230;)</p>

				
				
			</div>
		</article>
	</div>
<a href="https://theclemsoninsider.com" class="article__back">More The Clemson Insider</a>

		
	</div><!-- #content -->
</div><!-- #primary -->


<div id="secondary" class="widget-area container sidebar--follow" role="complementary">

	
	<aside id="sidebar-read-more" class="widget sidebar-upper">

		
			<div class="widget sidebar-ad top">
				<div id='acm-ad-tag-lawrence_dfp_desktop_top_300x250' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function(e) { googletag.display('acm-ad-tag-lawrence_dfp_desktop_top_300x250'); });</script></div>			</div>

		
		
		<div class="widget_text widget widget_custom_html" id="custom_html-2"><div class="textwidget custom-html-widget"><a target="_blank" href="https://fanatics.ncw6.net/c/2228998/621077/9663?subId1=TCIcontent" rel="noopener noreferrer"><img src="https://static.shareasale.com/image/7124/college_300x250_clemsontigers.jpg" border="0" alt="Clemson Tigers gear at Fanatics.com" /></a></div></div><div class="widget widget_usat_sidebar_top_posts_widget" id="usat_sidebar_top_posts_widget-2">		<div class="col1 right" id="sticky-sidebar">
				<div class="heading-small">
		<h2>Most <span>Popular</span></h2>
	</div>
	
					<article class="block standard-thumbnail" itemscope itemtype="http://schema.org/NewsArticle">
						<a style="background-image:url('https://theclemsoninsider.com/wp-content/uploads/sites/81/2020/11/Patrick-Jones-II.jpg?w=480');" data-track="mostshared" href="https://theclemsoninsider.com/2020/11/26/elliott-concerned-about-pitts-d-line/" title="Elliott concerned about Pitt&#039;s D-Line" class="img-holder link light" rel="nofollow" itemprop="url">
				<img src="https://theclemsoninsider.com/wp-content/uploads/sites/81/2020/11/Patrick-Jones-II.jpg?w=100&#038;h=100&#038;crop=1" alt="Elliott concerned about Pitt&#039;s D-Line" itemprop="image">

								<span class="ie-overlay-hack"></span>
											</a>
						<div class="mobile-date">
				2d			</div>
			<div class="text-block">
															 		<h2>
                        <a href="https://theclemsoninsider.com/2020/11/26/elliott-concerned-about-pitts-d-line/" rel="nofollow" itemprop="url">
                        145 shares                        </a>
			 		</h2>
			 									<p><a data-track="mostshared" href="https://theclemsoninsider.com/2020/11/26/elliott-concerned-about-pitts-d-line/" title="Elliott concerned about Pitt&#039;s D-Line" itemprop="url" >Elliott concerned about Pitt's D-Line</a></p>
				<p class="widget-date">November 26, 2020</p>
				<h2 class="widget-category"><a href="https://theclemsoninsider.com/category/feature-2/" class="category" itemprop="articleSection">Feature</a>				</h2>
							</div>
		</article>
				<article class="block standard-thumbnail" itemscope itemtype="http://schema.org/NewsArticle">
						<a style="background-image:url('https://theclemsoninsider.com/wp-content/uploads/sites/81/2020/11/Kenny-Pickett.jpg?w=480');" data-track="mostshared" href="https://theclemsoninsider.com/2020/11/27/venables-clemson-defense-not-overlooking-pickett/" title="Venables, Clemson defense not overlooking Pickett" class="img-holder link light" rel="nofollow" itemprop="url">
				<img src="https://theclemsoninsider.com/wp-content/uploads/sites/81/2020/11/Kenny-Pickett.jpg?w=100&#038;h=100&#038;crop=1" alt="Venables, Clemson defense not overlooking Pickett" itemprop="image">

								<span class="ie-overlay-hack"></span>
											</a>
						<div class="mobile-date">
				1d			</div>
			<div class="text-block">
															 		<h2>
                        <a href="https://theclemsoninsider.com/2020/11/27/venables-clemson-defense-not-overlooking-pickett/" rel="nofollow" itemprop="url">
                        88 shares                        </a>
			 		</h2>
			 									<p><a data-track="mostshared" href="https://theclemsoninsider.com/2020/11/27/venables-clemson-defense-not-overlooking-pickett/" title="Venables, Clemson defense not overlooking Pickett" itemprop="url" >Venables, Clemson defense not overlooking Pickett</a></p>
				<p class="widget-date">November 27, 2020</p>
				<h2 class="widget-category"><a href="https://theclemsoninsider.com/category/feature-2/" class="category" itemprop="articleSection">Feature</a>				</h2>
							</div>
		</article>
				<article class="block standard-thumbnail" itemscope itemtype="http://schema.org/NewsArticle">
						<a style="background-image:url('https://theclemsoninsider.com/wp-content/uploads/sites/81/2018/12/tre-lamar.jpg?w=480');" data-track="mostshared" href="https://theclemsoninsider.com/2020/11/26/network-change-clemson-pittsburgh-game/" title="Network Change: Clemson-Pittsburgh Game" class="img-holder link light" rel="nofollow" itemprop="url">
				<img src="https://theclemsoninsider.com/wp-content/uploads/sites/81/2018/12/tre-lamar.jpg?w=100&#038;h=100&#038;crop=1" alt="Network Change: Clemson-Pittsburgh Game" itemprop="image">

								<span class="ie-overlay-hack"></span>
											</a>
						<div class="mobile-date">
				2d			</div>
			<div class="text-block">
															 		<h2>
                        <a href="https://theclemsoninsider.com/2020/11/26/network-change-clemson-pittsburgh-game/" rel="nofollow" itemprop="url">
                        1.5k shares                        </a>
			 		</h2>
			 									<p><a data-track="mostshared" href="https://theclemsoninsider.com/2020/11/26/network-change-clemson-pittsburgh-game/" title="Network Change: Clemson-Pittsburgh Game" itemprop="url" >Network Change: Clemson-Pittsburgh Game</a></p>
				<p class="widget-date">November 26, 2020</p>
				<h2 class="widget-category"><a href="https://theclemsoninsider.com/category/football/" class="category" itemprop="articleSection">Football</a>				</h2>
							</div>
		</article>
				<article class="block standard-thumbnail" itemscope itemtype="http://schema.org/NewsArticle">
						<a style="background-image:url('https://theclemsoninsider.com/wp-content/uploads/sites/81/2020/11/Matt-Bockhorst.jpg?w=480');" data-track="mostshared" href="https://theclemsoninsider.com/2020/11/26/bockhorst-explains-why-players-were-so-frustrated-with-fsu/" title="Bockhorst explains why players were so frustrated with FSU" class="img-holder link light" rel="nofollow" itemprop="url">
				<img src="https://theclemsoninsider.com/wp-content/uploads/sites/81/2020/11/Matt-Bockhorst.jpg?w=100&#038;h=100&#038;crop=1" alt="Bockhorst explains why players were so frustrated with FSU" itemprop="image">

								<span class="ie-overlay-hack"></span>
											</a>
						<div class="mobile-date">
				2d			</div>
			<div class="text-block">
															 		<h2>
                        <a href="https://theclemsoninsider.com/2020/11/26/bockhorst-explains-why-players-were-so-frustrated-with-fsu/" rel="nofollow" itemprop="url">
                        4.8k shares                        </a>
			 		</h2>
			 									<p><a data-track="mostshared" href="https://theclemsoninsider.com/2020/11/26/bockhorst-explains-why-players-were-so-frustrated-with-fsu/" title="Bockhorst explains why players were so frustrated with FSU" itemprop="url" >Bockhorst explains why players were so frustrated with FSU</a></p>
				<p class="widget-date">November 26, 2020</p>
				<h2 class="widget-category"><a href="https://theclemsoninsider.com/category/football/" class="category" itemprop="articleSection">Football</a>				</h2>
							</div>
		</article>
				<article class="block standard-thumbnail" itemscope itemtype="http://schema.org/NewsArticle">
						<a style="background-image:url('https://theclemsoninsider.com/wp-content/uploads/sites/81/2018/06/christian-wilkins.jpg?w=361');" data-track="mostshared" href="https://theclemsoninsider.com/2020/11/26/swinney-still-finds-it-weird-clemson-is-not-playing-the-gamecocks/" title="Swinney still finds it weird Clemson is not playing the Gamecocks" class="img-holder link light" rel="nofollow" itemprop="url">
				<img src="https://theclemsoninsider.com/wp-content/uploads/sites/81/2018/06/christian-wilkins.jpg?w=100&#038;h=100&#038;crop=1" alt="Swinney still finds it weird Clemson is not playing the Gamecocks" itemprop="image">

								<span class="ie-overlay-hack"></span>
											</a>
						<div class="mobile-date">
				2d			</div>
			<div class="text-block">
															 		<h2>
                        <a href="https://theclemsoninsider.com/2020/11/26/swinney-still-finds-it-weird-clemson-is-not-playing-the-gamecocks/" rel="nofollow" itemprop="url">
                        107 shares                        </a>
			 		</h2>
			 									<p><a data-track="mostshared" href="https://theclemsoninsider.com/2020/11/26/swinney-still-finds-it-weird-clemson-is-not-playing-the-gamecocks/" title="Swinney still finds it weird Clemson is not playing the Gamecocks" itemprop="url" >Swinney still finds it weird Clemson is not playing the Gamecocks</a></p>
				<p class="widget-date">November 26, 2020</p>
				<h2 class="widget-category"><a href="https://theclemsoninsider.com/category/football/" class="category" itemprop="articleSection">Football</a>				</h2>
							</div>
		</article>
				<article class="block standard-thumbnail" itemscope itemtype="http://schema.org/NewsArticle">
						<a style="background-image:url('https://theclemsoninsider.com/wp-content/uploads/sites/81/2020/11/E.J.-Williams.jpg?w=480');" data-track="mostshared" href="https://theclemsoninsider.com/2020/11/26/with-2-receivers-down-clemson-turns-to-a-true-freshman/" title="With 2 receivers down, Clemson turns to a true freshman" class="img-holder link light" rel="nofollow" itemprop="url">
				<img src="https://theclemsoninsider.com/wp-content/uploads/sites/81/2020/11/E.J.-Williams.jpg?w=100&#038;h=100&#038;crop=1" alt="With 2 receivers down, Clemson turns to a true freshman" itemprop="image">

								<span class="ie-overlay-hack"></span>
											</a>
						<div class="mobile-date">
				2d			</div>
			<div class="text-block">
															 		<h2>
                        <a href="https://theclemsoninsider.com/2020/11/26/with-2-receivers-down-clemson-turns-to-a-true-freshman/" rel="nofollow" itemprop="url">
                        3.9k shares                        </a>
			 		</h2>
			 									<p><a data-track="mostshared" href="https://theclemsoninsider.com/2020/11/26/with-2-receivers-down-clemson-turns-to-a-true-freshman/" title="With 2 receivers down, Clemson turns to a true freshman" itemprop="url" >With 2 receivers down, Clemson turns to a true freshman</a></p>
				<p class="widget-date">November 26, 2020</p>
				<h2 class="widget-category"><a href="https://theclemsoninsider.com/category/football/" class="category" itemprop="articleSection">Football</a>				</h2>
							</div>
		</article>
				<article class="block standard-thumbnail" itemscope itemtype="http://schema.org/NewsArticle">
						<a style="background-image:url('https://theclemsoninsider.com/wp-content/uploads/sites/81/2019/11/aamir-simms.jpeg?w=418');" data-track="mostshared" href="https://theclemsoninsider.com/2020/11/26/tigers-win-space-coast-challenge-with-late-second-half-surge/" title="Tigers win Space Coast Challenge with late second-half surge" class="img-holder link light" rel="nofollow" itemprop="url">
				<img src="https://theclemsoninsider.com/wp-content/uploads/sites/81/2019/11/aamir-simms.jpeg?w=100&#038;h=100&#038;crop=1" alt="Tigers win Space Coast Challenge with late second-half surge" itemprop="image">

								<span class="ie-overlay-hack"></span>
											</a>
						<div class="mobile-date">
				2d			</div>
			<div class="text-block">
															 		<h2>
                        <a href="https://theclemsoninsider.com/2020/11/26/tigers-win-space-coast-challenge-with-late-second-half-surge/" rel="nofollow" itemprop="url">
                        491 shares                        </a>
			 		</h2>
			 									<p><a data-track="mostshared" href="https://theclemsoninsider.com/2020/11/26/tigers-win-space-coast-challenge-with-late-second-half-surge/" title="Tigers win Space Coast Challenge with late second-half surge" itemprop="url" >Tigers win Space Coast Challenge with late second-half surge</a></p>
				<p class="widget-date">November 26, 2020</p>
				<h2 class="widget-category"><a href="https://theclemsoninsider.com/category/basketball/" class="category" itemprop="articleSection">Basketball</a>				</h2>
							</div>
		</article>
		
		</div>
		</div><div class="widget widget_text" id="text-3">			<div class="textwidget"><div><a href="https://embed.air.tv/v1/twoview_bootstrap.js?organization=TfWx9U5HSZKgx4RN1rcRbQ">https://embed.air.tv/v1/twoview_bootstrap.js?organization=TfWx9U5HSZKgx4RN1rcRbQ</a></div></div>
		</div>
		
			<div class="widget sidebar-ad bottom">
				<div id='acm-ad-tag-lawrence_dfp_desktop_bottom_300x250' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function(e) { googletag.display('acm-ad-tag-lawrence_dfp_desktop_bottom_300x250'); });</script></div>			</div>

		
		
<div id="footer-info">
	<p class="footer__logo">
		<a href="http://theclemsoninsider.com" rel="nofollow" target="_blank">
			<img src="https://theclemsoninsider.com/wp-content/uploads/sites/81/2018/03/usa_today_sportsdp_color_extreme_horiz-193x41.jpeg" alt="The Clemson Insider">
		</a>
	</p>

	<div class="togglee">
		<div class="menu-footer-navigation-container"><ul id="menu-footer-navigation" class="menu"><li id="menu-item-75042" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-75042"><a href="https://theclemsoninsider.com/the-tci-staff/">Meet The TCI Staff</a></li>
</ul></div>
		
		<p class="poweredby-wordpress">
			Powered by <a href="https://wpvip.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit&#038;utm_term=theclemsoninsider.com" rel="generator nofollow" class="powered-by-wpcom">WordPress.com VIP</a>		</p>
	</div>

	<p class="toggler">
		<a href="#footer-toggle" rel="nofollow">
			More Information		</a>
		<span class="arrow-up"></span>
	</p>

	<script type="text/javascript">
		var footer_expand_text   = "More Information";
		var footer_collapse_text = "Less Information";
	</script>
</div>

	</aside>

	<div id="secondary-bottom"></div>

</div><!-- #secondary -->
<div style="clear:both;"></div>
			</div><!-- Site Main -->
		</div><!-- Wrapper Holder -->
	</div><!-- Wrapper -->

	<div id='acm-ad-tag-' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function(e) { googletag.display('acm-ad-tag-'); });</script></div>
	<div class="mobile-nav" id="mobile-nav-holder">
	<div class="mobile-nav__header">
					<img class="mobile-nav__logo" src="https://theclemsoninsider.com/wp-content/uploads/sites/81/2017/10/tci_tiger.png" alt="The Clemson Insider">
				<a class="mobile-nav__breadcrumb" href="https://theclemsoninsider.com">Home</a>
		<span class="mobile-nav__close"></span>
	</div>
			<ul class="mobile-nav__social ">
					<li class="mobile-nav__item mobile-nav__item--stalk">Follow us&hellip;</li>
							<li class="mobile-nav__item mobile-nav__item--social mobile-nav__item--facebook">
				<a href="https://www.facebook.com/theclemsoninsider" class="mobile-nav__item-link"></a>
			</li>
					<li class="mobile-nav__item mobile-nav__item--social mobile-nav__item--twitter">
				<a href="http://twitter.com/clemsoninsider" class="mobile-nav__item-link"></a>
			</li>
			</ul>
	<ul class="mobile-nav__menu">
		<li class="mobile-nav__item mobile-nav__item--home"><a href="/">Home</a></li>
<li class="mobile-nav__item mobile-nav__item--forums mobile-nav__item--parent"><a href="http://forums.theclemsoninsider.com/">Forums</a>
<ul class="sub-menu">
	<li class="mobile-nav__item mobile-nav__item--the-rock"><a href="http://forums.theclemsoninsider.com/forumdisplay.php?f=2">The Rock</a></li>
	<li class="mobile-nav__item mobile-nav__item--all-in-recruiting"><a href="http://forums.theclemsoninsider.com/forumdisplay.php?f=14">All In Recruiting</a></li>
	<li class="mobile-nav__item mobile-nav__item--tweet-that"><a href="http://forums.theclemsoninsider.com/forumdisplay.php?f=15">Tweet That</a></li>
	<li class="mobile-nav__item mobile-nav__item--joes-place"><a href="http://forums.theclemsoninsider.com/forumdisplay.php?f=11">Joe's Place</a></li>
</ul>
</li>
<li class="mobile-nav__item mobile-nav__item--football mobile-nav__item--parent"><a href="https://theclemsoninsider.com/category/football/">Football</a>
<ul class="sub-menu">
	<li class="mobile-nav__item mobile-nav__item--depth-tracker"><a href="https://theclemsoninsider.com/depth-tracker/">Depth Tracker</a></li>
	<li class="mobile-nav__item mobile-nav__item--football-roster"><a href="https://theclemsoninsider.com/football-roster/">Football Roster</a></li>
	<li class="mobile-nav__item mobile-nav__item--football-schedule"><a href="https://theclemsoninsider.com/football-schedule/">Football Schedule</a></li>
</ul>
</li>
<li class="mobile-nav__item mobile-nav__item--baseball mobile-nav__item--parent"><a href="https://theclemsoninsider.com/category/baseball/">Baseball</a>
<ul class="sub-menu">
	<li class="mobile-nav__item mobile-nav__item--2015-baseball-commits"><a href="https://theclemsoninsider.com/2015-baseball-commits/">2015 Baseball Commits</a></li>
	<li class="mobile-nav__item mobile-nav__item--2016-baseball-commits"><a href="https://theclemsoninsider.com/2016-baseball-commits/">2016 Baseball Commits</a></li>
	<li class="mobile-nav__item mobile-nav__item--2017-baseball-commits"><a href="https://theclemsoninsider.com/2017-baseball-commits/">2017 Baseball Commits</a></li>
	<li class="mobile-nav__item mobile-nav__item--2018-baseball-commits"><a href="https://theclemsoninsider.com/2018-baseball-commits/">2018 Baseball Commits</a></li>
	<li class="mobile-nav__item mobile-nav__item--2019-baseball-commits"><a href="https://theclemsoninsider.com/2019-baseball-commits/">2019 Baseball Commits</a></li>
	<li class="mobile-nav__item mobile-nav__item--2020-baseball-commits"><a href="https://theclemsoninsider.com/2020-baseball-commits/">2020 Baseball Commits</a></li>
	<li class="mobile-nav__item mobile-nav__item--2021-baseball-commits"><a href="https://theclemsoninsider.com/2021-baseball-commits/">2021 Baseball Commits</a></li>
	<li class="mobile-nav__item mobile-nav__item--baseball-schedule"><a href="https://theclemsoninsider.com/baseball-schedule/">Baseball Schedule</a></li>
	<li class="mobile-nav__item mobile-nav__item--baseball-roster"><a href="https://theclemsoninsider.com/baseball-roster-3/">Baseball Roster</a></li>
</ul>
</li>
<li class="mobile-nav__item mobile-nav__item--recruiting mobile-nav__item--parent"><a href="https://theclemsoninsider.com/category/recruiting/">Recruiting</a>
<ul class="sub-menu">
	<li class="mobile-nav__item mobile-nav__item--2017-football-commitments"><a href="https://theclemsoninsider.com/2017-football-recruits/">2017 Football Commitments</a></li>
	<li class="mobile-nav__item mobile-nav__item--2018-football-commitments"><a href="https://theclemsoninsider.com/2018-football-commitments/">2018 Football Commitments</a></li>
	<li class="mobile-nav__item mobile-nav__item--2019-football-commitments"><a href="https://theclemsoninsider.com/2019-football-commitments/">2019 Football Commitments</a></li>
	<li class="mobile-nav__item mobile-nav__item--2020-football-commitments"><a href="http://recruiting.theclemsoninsider.com/prospects/2020?status=commits">2020 Football Commitments</a></li>
	<li class="mobile-nav__item mobile-nav__item--2021-commitments"><a href="http://recruiting.theclemsoninsider.com/prospects/2021?status=commits">2021 Commitments</a></li>
	<li class="mobile-nav__item mobile-nav__item--football-recruits"><a href="http://recruiting.theclemsoninsider.com/prospects/2020">Football Recruits</a></li>
</ul>
</li>
<li class="mobile-nav__item mobile-nav__item--basketball mobile-nav__item--parent"><a href="https://theclemsoninsider.com/category/basketball/">Basketball</a>
<ul class="sub-menu">
	<li class="mobile-nav__item mobile-nav__item--basketball-roster"><a href="https://theclemsoninsider.com/basketball-roster/">Basketball Roster</a></li>
	<li class="mobile-nav__item mobile-nav__item--basketball-schedule"><a href="https://theclemsoninsider.com/basketball-schedule/">Basketball Schedule</a></li>
</ul>
</li>
<li class="mobile-nav__item mobile-nav__item--galleries"><a href="http://recruiting.theclemsoninsider.com/gallery">Galleries</a></li>
<li class="mobile-nav__item mobile-nav__item--olympic"><a href="https://theclemsoninsider.com/category/olympic/">Olympic</a></li>
<li class="mobile-nav__item mobile-nav__item--tcis-student-alumni"><a href="https://theclemsoninsider.com/tcis-alumni/">TCI's Student Alumni</a></li>
	</ul>
	<ul class="mobile-nav__footer-menu">
		<li id="menu-item-75042" class="mobile-nav__item mobile-nav__item--meet-the-tci-staff"><a href="https://theclemsoninsider.com/the-tci-staff/">Meet The TCI Staff</a></li>

		
					<li class="mobile-nav__item mobile-nav__item--vipcom">
				Powered by <a href="https://wpvip.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit&#038;utm_term=theclemsoninsider.com" rel="generator nofollow" class="powered-by-wpcom">WordPress.com VIP</a>			</li>
			</ul>

			<a
			class="mobile-nav__footer"
			href="http://theclemsoninsider.com"
			target="_blank"
			title="The Clemson Insider"
			rel="nofollow"
		>
			<img class="mobile-nav__footer-image" src="https://theclemsoninsider.com/wp-content/uploads/sites/81/2018/03/usa_today_sportsdp_color_extreme_horiz-193x41.jpeg">
		</a>
	</div>
<div id="main_ad" style="height:1px; width:1px; overflow:auto;position: absolute;left: -999em;"><!--AD UNIT 4--></div><link rel='stylesheet' id='all-css-0' href='https://theclemsoninsider.com/wp-content/themes/usatoday-lawrence/modules/zergnet/css/zergnet.css?m=1601498197g' type='text/css' media='all' />
<script src='https://native.sharethrough.com/assets/sfp.js?ver=1' id='sharethrough-native-responsive-js'></script>
<script type='text/javascript' src='https://theclemsoninsider.com/_static/??-eJydzNEKwjAMQNEfcst0wzfxUyS0YaasaW3Slf29IvrqwOd7uNBy55IYiYHdKZJCVbTkcesWbIXEEcTk6/Iq6Dt1hbMpBIWMBWOqYn3QA/z/ETRe6TYXXNm274zFLdXTW4RHpbJBZXCpUB9ZfqvGfibbdzkpGyfZl5GkftQ1Xo7nYRqGcZxO4Ql0l3c7'></script>
<script src='https://theclemsoninsider.com/wp-includes/js/dist/vendor/wp-polyfill.min.js?ver=7.4.4' id='wp-polyfill-js'></script>
<script id='wp-polyfill-js-after'>
( 'fetch' in window ) || document.write( '<script src="https://theclemsoninsider.com/wp-includes/js/dist/vendor/wp-polyfill-fetch.min.js?ver=3.0.0"></scr' + 'ipt>' );( document.contains ) || document.write( '<script src="https://theclemsoninsider.com/wp-includes/js/dist/vendor/wp-polyfill-node-contains.min.js?ver=3.42.0"></scr' + 'ipt>' );( window.DOMRect ) || document.write( '<script src="https://theclemsoninsider.com/wp-includes/js/dist/vendor/wp-polyfill-dom-rect.min.js?ver=3.42.0"></scr' + 'ipt>' );( window.URL && window.URL.prototype && window.URLSearchParams ) || document.write( '<script src="https://theclemsoninsider.com/wp-includes/js/dist/vendor/wp-polyfill-url.min.js?ver=3.6.4"></scr' + 'ipt>' );( window.FormData && window.FormData.prototype.keys ) || document.write( '<script src="https://theclemsoninsider.com/wp-includes/js/dist/vendor/wp-polyfill-formdata.min.js?ver=3.0.12"></scr' + 'ipt>' );( Element.prototype.matches && Element.prototype.closest ) || document.write( '<script src="https://theclemsoninsider.com/wp-includes/js/dist/vendor/wp-polyfill-element-closest.min.js?ver=2.0.2"></scr' + 'ipt>' );
</script>
<script type='text/javascript' src='https://theclemsoninsider.com/_static/??/wp-includes/js/dist/dom-ready.min.js,/wp-includes/js/dist/i18n.min.js?m=1604003342j'></script>
<script id='wp-a11y-js-translations'>
( function( domain, translations ) {
	var localeData = translations.locale_data[ domain ] || translations.locale_data.messages;
	localeData[""].domain = domain;
	wp.i18n.setLocaleData( localeData, domain );
} )( "default", { "locale_data": { "messages": { "": {} } } } );
</script>
<script src='https://theclemsoninsider.com/wp-includes/js/dist/a11y.min.js?ver=13971b965470c74a60fa32d392c78f2f' id='wp-a11y-js'></script>
<script id='jquery-ui-autocomplete-js-extra'>
var uiAutocompleteL10n = {"noResults":"No results found.","oneResult":"1 result found. Use up and down arrow keys to navigate.","manyResults":"%d results found. Use up and down arrow keys to navigate.","itemSelected":"Item selected."};
</script>
<script id='usatoday-sticky-inline-videos-script-js-extra'>
var stickyInlineVideosOptions = {"side":"right","hide":"Hide video"};
</script>
<script id='lawrence-ads-js-js-extra'>
var _LAWRENCE_ADS_EXPORTS = {"ad_refresh":{"seconds":"60","refresh_type":"all","distance":"2000","active":"0"}};
</script>
<script type='text/javascript' src='https://theclemsoninsider.com/_static/??-eJyVj1EKwjAQRC9kutEW/8SzxGTRbZPd2mxaentbURAVQZivYeYxA1NviH0sATO0i64FhxkKgSsqXlIfUbFKxFWbN7CkvbAiK/SxnIkzlOxUgpvN08hKvpsXaiRGM1JAuaO/+e9QvWDCF2Z004Dsce1HOj3mVV6kI/ynnNzng195F9Ztx3TY7m1jbV03u/YGZARwVg=='></script>
<script src='https://www.googletagservices.com/tag/js/gpt.js?ver=1.0' id='lawrence-confiant-js-js'></script>
<script type='text/javascript' src='https://theclemsoninsider.com/_static/??-eJytzD0OwjAMQOELkbrQig1xFss2kCh/ih1BOT3tQCdG1qenD57V+UyxsygEhZ5ZmlJpMiSfh6AHWA8q2SQbpO5q7HefFVSw0QMkopqn2kQV2KttyA1JTJ1S89V+OV+kK1phXHY14ntxsSA7ea0nC2/eXv9qBb2my/E8zuM4TfMpfAATAGOM'></script>
<script id='onesignal-sdk-js-extra'>
var OneSignalOptions = {"appId":"e48ac860-551b-4541-951a-ca6ac5038c54"};
</script>
<script type="text/javascript" src="//cdn.onesignal.com/sdks/OneSignalSDK.js?ver=5.0" async="async"></script>

				<script type="text/javascript">
					var OneSignal = window.OneSignal || [];
					setTimeout(
						function() {
							OneSignal.push(function() {
								OneSignal.init({"appId":"e48ac860-551b-4541-951a-ca6ac5038c54"})
							});
						},
						10000
					);
				</script>
			<script id='wasabi-article-js-extra'>
var wasabiFacebookReferral = "0";
</script>
<script id='wasabi-main-js-extra'>
var wasabiAdFollowOptions = {"headerAdPosition":"0","enable":"1","headerHeight":"60","stickyAdSettings":"{\"66\":{\"follow\":\"0\",\"minWidth\":\"1024\",\"stickTime\":\"4\"},\"90\":{\"follow\":\"0\",\"minWidth\":\"1024\",\"stickTime\":\"4\"},\"250\":{\"follow\":\"0\",\"minWidth\":\"1024\",\"stickTime\":\"4\"}}"};
</script>
<script type='text/javascript' src='https://theclemsoninsider.com/_static/??-eJydjtEKwjAMRX/ILdUN38RvSdswUtp0LKnDv3cK+m4f7zkcuLCvQ6hiJAZrbguLQlO0GvE5fMGOip4hHco465j0BP91gg9e0LhKR6wcyePWUeJmHDJ1lAX5d5Ul5BZJ3/yYVDzFsXz8vdzOVzc7N03zJb0AWkV8/Q=='></script>
<script src='https://www.zergnet.com/zerg.js?id=82059&#038;ver=1.0' id='zergnet-js'></script>
<script src='https://platform-api.sharethis.com/js/sharethis.js#product=sop-wordpress-plugin' id='sop-script-js'></script>
<script type='text/javascript' src='https://stats.wp.com/e-202048.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.1',blog:'175784995',post:'552984',tz:'-5',srv:'theclemsoninsider.com'} ]);
	_stq.push([ 'clickTrackerInit', '175784995', '552984' ]);
</script>
</body>
</html>


<!--
$$\
$$ |
$$ |      $$$$$$\  $$\  $$\  $$\  $$$$$$\   $$$$$$\  $$$$$$$\   $$$$$$$\  $$$$$$\
$$ |      \____$$\ $$ | $$ | $$ |$$  __$$\ $$  __$$\ $$  __$$\ $$  _____|$$  __$$\
$$ |      $$$$$$$ |$$ | $$ | $$ |$$ |  \__|$$$$$$$$ |$$ |  $$ |$$ /      $$$$$$$$ |
$$ |     $$  __$$ |$$ | $$ | $$ |$$ |      $$   ____|$$ |  $$ |$$ |      $$   ____|
$$$$$$$$\$$$$$$$ |\$$$$$\$$$$  |$$ |      \$$$$$$$\ $$ |  $$ |\$$$$$$$\ \$$$$$$$\
\________|\_______| \_____\____/ \__|       \_______|\__|  \__| \_______| \_______|

Brought to you by your good friends at USA Today Sports.
-->
